summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@novell.com>2011-01-24 14:31:23 +0200
committerTor Lillqvist <tlillqvist@novell.com>2011-01-24 16:27:05 +0200
commitc88741679524d31c3cc70a281ebfcf5d41e07eac (patch)
tree5fce177b6dc754c3207c5a2f08ece9ebf3e3f43c /configure.in
parent520bb3a8ec66c8f177e63a635f3aed42f9513576 (diff)
Clean up messages from the Microsoft assembler configury a bit
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4714e0320773..a0e040d067ad 100755
--- a/configure.in
+++ b/configure.in
@@ -6060,16 +6060,19 @@ else
assembler_bin=bin/amd64
fi
if test "$_os" = "WINNT" -a "$WITH_MINGW" != "yes"; then
- AC_MSG_CHECKING([$assembler assembler path])
if test -n "$with_asm_home"; then
with_asm_home=`cygpath -u "$with_asm_home"`
fi
- if test ! -x "$with_asm_home/$assembler"; then
+ if test -x "$with_asm_home/$assembler"; then
+ AC_MSG_CHECKING([$assembler assembler path])
+ AC_MSG_RESULT([$with_asm_home/$assembler])
+ else
AC_PATH_PROG(ML_EXE, $assembler)
if test -z "$ML_EXE"; then
+ AC_MSG_CHECKING([$with_cl_home/$assembler_bin/$assembler])
if test -x "$with_cl_home/$assembler_bin/$assembler"; then
with_asm_home=$with_cl_home/$assembler_bin
- AC_MSG_RESULT([found ($with_asm_home)])
+ AC_MSG_RESULT([found])
else
AC_MSG_ERROR([Configure did not find $assembler assembler.])
fi
@@ -6077,7 +6080,6 @@ if test "$_os" = "WINNT" -a "$WITH_MINGW" != "yes"; then
with_asm_home="ASM_IN_PATH"
fi
fi
- AC_MSG_RESULT([$ASM_HOME])
else
with_asm_home="NO_ASM_HOME"
fi