summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThorsten Behrens <thb@openoffice.org>2010-09-21 17:40:45 +0200
committerThorsten Behrens <thb@openoffice.org>2010-09-21 17:40:45 +0200
commitd8128261e661247d435c8b0cb49bcf25f127101e (patch)
treec9ab4e76b9f36e9a664441232e8674409649f377 /configure.in
parent7ea508e89e22cd48c8868f6e132aa79c0a36bc04 (diff)
Properly catch unknown cpu number situation
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6dfa4dd6aea4..69b5529fb1b4 100644
--- a/configure.in
+++ b/configure.in
@@ -7387,7 +7387,7 @@ BUILD_NCPUS=`grep $'^processor\t*:' /proc/cpuinfo | wc -l`
if test "z$with_num_cpus" != "z"; then
BUILD_NCPUS=$with_num_cpus
fi
-if test "$BUILD_NCPUS" = "0" ; then
+if echo "$BUILD_NCPUS" | $EGREP -q '^[[[:space:]]]*0[[[:space:]]]*$' ; then
BUILD_NCPUS=1
fi
AC_MSG_RESULT([$BUILD_NCPUS])