summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-07-20 14:11:53 +0200
committerStephan Bergmann <sbergman@redhat.com>2012-07-20 14:11:53 +0200
commit1e0971c3dd8bb303176f058bcd53682de9241616 (patch)
tree15f992eb6183156389839f6a48ce09b96a7a62c2 /configure.in
parent37c67a137882cc1a9e113552dcab42a7d6337358 (diff)
Support for --with-java-target-version in gbuild
...had been missing. Old dmake-based build system did not add -source/-target when using gcj (unless gcj really was Eclipse Java Compiler, in which case those -source/-target values were tunneled in via JAVAFLAGS)---hopefully all this is no longer necessary. (Also removed a single use of JAVA_TARGET_FLAG that was nowhere defined.) Change-Id: Ic3596691b622be45e151333981f8f236d11825b4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 081c6f0d4671..b41fa09886a9 100644
--- a/configure.in
+++ b/configure.in
@@ -1623,8 +1623,8 @@ AC_ARG_WITH(java,
AC_ARG_WITH(java_target_version,
AS_HELP_STRING([--with-java-target-version],
[Generate class files that will work on JVMs with the specified version.
- For example, use --with-java-target-version=1.4 to make sure that the
- application will work with JVM 1.4 even when compiled with JDK 1.5.])
+ For example, use --with-java-target-version=1.5 to make sure that the
+ application will work with JVM 1.5 even when compiled with JDK 1.6.])
[
This option is ignored when you compile with gcj/gij.
@@ -5336,8 +5336,6 @@ if test "$SOLAR_JAVA" != ""; then
AC_MSG_CHECKING([re-checking JDK])
JDK=gcj
AC_MSG_RESULT([checked (ecj)])
- #TODO: what's to do here? some switch to do 1.5 compiling?
- JAVAFLAGS="-source 1.5 -target 1.5"
_gij_longver="40200"
fi
fi
@@ -5823,7 +5821,6 @@ AC_SUBST(CLASSPATH)
AC_SUBST(JAVALIB)
AC_SUBST(JAVACOMPILER)
AC_SUBST(JAVADOC)
-AC_SUBST(JAVAFLAGS)
AC_SUBST(JAVAINTERPRETER)
AC_SUBST(JAVAIFLAGS)
AC_SUBST(JAVA_HOME)