summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-02-17 13:54:25 +0200
committerTor Lillqvist <tlillqvist@suse.com>2012-02-17 18:08:15 +0200
commit18f4ff23179620e834aa3ebd83a2e15c2f77cbe1 (patch)
tree3387af70fde0488107d986be90b01dd216762868 /configure.in
parenteed2695cd5d63bdaf8b02c5cbf3a7e4017e18173 (diff)
Recommend to use NDK r7b
Drop compiler options -fexceptions -frtti for Android, I hope they are taken care of by the makefilery where needed. At least either -fexceptions or -fno-exceptions is used for each C++ compilation as far as I know. Not so sure about RTTI, let's see.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2459b76baf1d..486d061e758f 100644
--- a/configure.in
+++ b/configure.in
@@ -111,7 +111,7 @@ if test -n "$with_android_ndk"; then
ANDROIDCFLAGS="-march=armv7-a -mfloat-abi=softfp -mthumb -mfpu=neon -Wl,--fix-cortex-a8 --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-arm -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/libs/armeabi-v7a"
test -z "$CC" && CC="$ANDROID_ABI_PREBUILT_BIN/arm-linux-androideabi-gcc $ANDROIDCFLAGS"
- test -z "$CXX" && CXX="$ANDROID_ABI_PREBUILT_BIN/arm-linux-androideabi-g++ $ANDROIDCFLAGS -I $ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/include -I$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/libs/armeabi-v7a/include -fexceptions -frtti"
+ test -z "$CXX" && CXX="$ANDROID_ABI_PREBUILT_BIN/arm-linux-androideabi-g++ $ANDROIDCFLAGS -I $ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/include -I$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/libs/armeabi-v7a/include"
fi
AC_SUBST(ANDROID_NDK_HOME)