summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-02-17 09:49:27 +0100
committerDavid Tardon <dtardon@redhat.com>2012-02-17 15:53:57 +0100
commit2afa9317cd2a137154c1ea06a2449308d26db8ea (patch)
treed966b2c913d6e4986f5231e4ae88aba6671b6b53 /configure.in
parente1462d24f47c56cc5e4d8cbec09fb755ce4b08fe (diff)
allow using system boost in cross-compilation build
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b3c2258b2e22..5d50dbb58be8 100644
--- a/configure.in
+++ b/configure.in
@@ -1933,6 +1933,10 @@ dnl ===================================================================
dnl options for stuff used during cross-compilation build
dnl ===================================================================
+AC_ARG_WITH(system-boost-for-build,
+ AS_HELP_STRING([--with-system-boost-for-build],
+ [Use boost/libxslt already on system for build tools (cross-compilation only).]))
+
AC_ARG_WITH(system-cppunit-for-build,
AS_HELP_STRING([--with-system-cppunit-for-build],
[Use cppunit/libxslt already on system for build tools (cross-compilation only).]))
@@ -3175,6 +3179,7 @@ if test "$cross_compiling" = "yes"; then
test $with_java = no && sub_conf_opts="$sub_conf_opts --without-java"
test $with_junit = no && sub_conf_opts="$sub_conf_opts --without-junit"
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
+ test -n "$with_system_boost_for_build" && sub_conf_opts="$sub_conf_opts --with-system-boost"
test -n "$with_system_cppunit_for_build" && sub_conf_opts="$sub_conf_opts --with-system-cppunit"
test -n "$with_system_libxml_for_build" && sub_conf_opts="$sub_conf_opts --with-system-libxml"
./configure \