summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2012-02-17 20:11:34 +0000
committerCaolán McNamara <caolanm@redhat.com>2012-02-17 20:11:34 +0000
commitaf75ceb873e55fc2f252c4b02ea3d536470cfb87 (patch)
tree570cd2c1d72d87db207d8cc568b2ddbfd3fa52b0 /configure.in
parent7f267db9b30fb90fe53844f659d4efa599034b5c (diff)
fix build, WANT_X11 is a variable
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index e424560707ae..413dec0dbbc7 100644
--- a/configure.in
+++ b/configure.in
@@ -7345,7 +7345,7 @@ fi
dnl ===================================================================
dnl Check for nsplugin
dnl ===================================================================
-AC_MSG_CHECKING([wether to build nsplugin extension])
+AC_MSG_CHECKING([whether to build nsplugin extension])
ENABLE_NSPLUGIN=NO
if test "$enable_nsplugin" != "no"; then
if test "$enable_gtk" != "no"; then
@@ -7359,6 +7359,7 @@ else
fi
AC_SUBST(ENABLE_NSPLUGIN)
+AC_MSG_CHECKING([whether to use X11])
dnl ***************************************
dnl testing for X libraries and includes...
dnl ***************************************
@@ -7366,8 +7367,9 @@ WANT_X11="no"
if test $_os != Darwin -a $_os != WINNT -a $_os != Android -a $_os != iOS -a "$enable_headless" != "yes"; then
WANT_X11="yes"
fi
+AC_MSG_RESULT([$WANT_X11])
-if test WANT_X11 = "yes"; then
+if test "$WANT_X11" = "yes"; then
AC_PATH_X
AC_PATH_XTRA
CPPFLAGS="$CPPFLAGS $X_CFLAGS"
@@ -7420,7 +7422,7 @@ if test "$XINC" != "no_x_includes" -a "$XINC" != "/usr/include" ; then
fi
AC_SUBST(XLIB)
-if test WANT_X11 = "yes"; then
+if test "$WANT_X11" = "yes"; then
dnl ===================================================================
dnl Check for Composite.h for Mozilla plugin
dnl ===================================================================
@@ -7440,7 +7442,7 @@ dnl ===================================================================
dnl Check for system Xrender
dnl ===================================================================
AC_MSG_CHECKING([whether to use Xrender])
-if test WANT_X11 = "yes" -a "$test_xrender" = "yes"; then
+if test "$WANT_X11" = "yes" -a "$test_xrender" = "yes"; then
AC_MSG_RESULT([yes])
AC_CHECK_LIB([Xrender], [XRenderQueryVersion], [:],
[AC_MSG_ERROR(libXrender not found or functional)], [])
@@ -7458,7 +7460,7 @@ dnl ===================================================================
dnl Check for XRandr
dnl ===================================================================
AC_MSG_CHECKING([whether to enable RandR support])
-if test WANT_X11 = "yes" -a "$test_randr" = "yes" -a \( "$enable_randr" = "yes" -o "$enable_randr" = "TRUE" \) ; then
+if test "$WANT_X11" = "yes" -a "$test_randr" = "yes" -a \( "$enable_randr" = "yes" -o "$enable_randr" = "TRUE" \) ; then
if test -z "$enable_randr_link" -o "$enable_randr_link" = "no"; then
XRANDR_DLOPEN="TRUE"
AC_MSG_RESULT([configured to dlopen libXrandr at runtime])