summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorVladimir Glazounov <vg@openoffice.org>2009-03-17 13:46:42 +0000
committerVladimir Glazounov <vg@openoffice.org>2009-03-17 13:46:42 +0000
commit82708306d974e9f76a43f51ca64547d2da539e42 (patch)
tree5a5775dbc9c3105004c7c7887e8793b10bcd3dc5 /configure.in
parent416d7a0fba60573e27ab2388ea4ce3a023b5e2d8 (diff)
CWS-TOOLING: integrate CWS configure24_DEV300
2009-03-06 10:31:03 +0100 rene r268982 : #i10000# more syntax 2009-03-06 09:55:08 +0100 rene r268978 : #i10000# syntax (thanks tinderbox) 2009-03-06 09:52:35 +0100 rene r268976 : #i99864# $JRETOOLKITDIR also need to be ifed 2009-03-05 18:22:24 +0100 rene r268935 : #i99864# readd support for lemote 2009-03-05 17:58:36 +0100 rene r268934 : fix description 2009-03-05 17:56:11 +0100 rene r268933 : CWS-TOOLING: rebase CWS configure24 to branches/OOO310@268862 (milestone: OOO310:m4) 2009-03-05 15:11:07 +0100 rene r268909 : #i10000# error out if libdb not valid #i99924# force ICU 4.x 2009-03-04 14:15:16 +0100 rene r268825 : #i99864# OpenJDK has mipsel as path, same as gcj 2009-03-03 09:50:31 +0100 rene r268710 : #i10000# fix MIPS 2009-02-27 13:40:07 +0100 rene r268590 : #i99490# allow db 4.7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index a0af3c27906f..33950defa86d 100644
--- a/configure.in
+++ b/configure.in
@@ -460,7 +460,7 @@ AC_ARG_WITH(libfonts-jar,
[ LIBFONTS_JAR="$withval"
])
AC_ARG_WITH(libserializer-jar,
-[ --libserializer-jar=JARFILE Specify path to jarfile manually ],
+[ --with-libserializer-jar=JARFILE Specify path to jarfile manually ],
[ LIBSERIALIZER_JAR="$withval"
])
AC_ARG_WITH(libbase-jar,
@@ -3627,7 +3627,7 @@ if test -n "$with_system_db" -o -n "$with_system_libs" && \
], []
)
AC_MSG_CHECKING([whether db is at least 4.1])
- for v in 1 2 3 4 5 6; do
+ for v in `seq 1 7`; do
AC_TRY_RUN([
#include <db.h>
@@ -3641,7 +3641,7 @@ int main(int argc, char **argv) {
AC_MSG_RESULT([OK])
DB_VERSION=4.$DB_VERSION_MINOR
else
- AC_MSG_RESULT([no. you need at least db 4.1])
+ AC_MSG_ERROR([no. you need at least db 4.1])
fi
# does not work :/
#AC_CHECK_LIB(db, db_create, [],
@@ -4252,14 +4252,12 @@ if test -n "$with_system_icu" -o -n "$with_system_libs" && \
#include <unicode/uversion.h>
int main(int argc, char **argv) {
- if(U_ICU_VERSION_MAJOR_NUM < 3)
- return 1;
- else if(U_ICU_VERSION_MAJOR_NUM == 3 && U_ICU_VERSION_MINOR_NUM < 6)
+ if(U_ICU_VERSION_MAJOR_NUM < 4)
return 1;
else
return 0;
}
- ], [AC_MSG_RESULT(OK)], [AC_MSG_ERROR([not suitable, only >= 3.6 supported currently])])
+ ], [AC_MSG_RESULT(OK)], [AC_MSG_ERROR([not suitable, only >= 4.0 supported currently])])
AC_LANG_POP([C++])
else
AC_MSG_RESULT([internal])