summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorVladimir Glazounov <vg@openoffice.org>2009-03-12 22:38:26 +0000
committerVladimir Glazounov <vg@openoffice.org>2009-03-12 22:38:26 +0000
commita8430dc185dbc6d3a3da987bd0f09925bf3edf3d (patch)
tree30efc2e68816dc9a93ebe16fd19d13582b4beb81 /configure.in
parent2011428e8d1c0fe0cbf318111ffab93616bc0292 (diff)
CWS-TOOLING: integrate CWS mingwport17
2009-02-02 09:09:07 +0100 tono r267246 : i#98723#: Less conditionals in libs.mk for mingw 2009-02-02 09:06:03 +0100 tono r267244 : i#98722#: Skip building ldump in mingw 2009-02-02 09:04:05 +0100 tono r267243 : i#98721#: Improve symbol extraction in mingw 2009-02-02 09:02:07 +0100 tono r267242 : i#98720#: Improve strip performance in mingw 2009-02-02 08:59:36 +0100 tono r267241 : i#98719#: Copy mingw multithread runtime in external 2009-02-02 08:55:09 +0100 tono r267240 : i#98718#: Cleanup cygwin workaround for mingw 2009-02-02 08:53:33 +0100 tono r267239 : i#98718#: Cleanup cygwin workaround for mingw 2009-02-02 08:50:36 +0100 tono r267237 : i#98717#: Avoid MSVC version check in mingw configure 2009-01-28 22:28:53 +0100 tono r267088 : i#97608#: Remove Guiddef.h inclusion 2009-01-28 22:24:23 +0100 tono r267087 : i#96980#: cairo dll name is different in mingw build 2009-01-28 22:19:19 +0100 tono r267086 : i#96731#: MinGW port fro embedserv update
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index a446c4d8d6cf..a0af3c27906f 100644
--- a/configure.in
+++ b/configure.in
@@ -1758,7 +1758,7 @@ dnl ===================================================================
dnl .NET needs special treatment
dnl ===================================================================
if test "$_os" = "WINNT"; then
-if test "$COMEX" -ge "10"; then
+if test "$WITH_MINGWIN" = "yes" || test "$COMEX" -ge "10"; then
dnl Check midl.exe
AC_PATH_PROG(MIDL_PATH, midl.exe)
if test -n "$MIDL_PATH";then
@@ -5067,7 +5067,7 @@ fi
dnl ===================================================================
dnl Windows builds - use oowintool to copy CRT dlls and manifest
dnl ===================================================================
-if test "$_os" = "WINNT"; then
+if test "$_os" = "WINNT" -a "$WITH_MINGWIN" != "yes"; then
if ./oowintool --msvc-copy-dlls ./external/msvcp ; then
:
else
@@ -5101,7 +5101,7 @@ dnl ===================================================================
dnl Windows builds with VS 2003/2005/2008 need instmsia.exe and instmsiw.exe in external/msi
dnl ===================================================================
if test "$_os" = "WINNT"; then
- if test "$COMEX" -ge "10"; then
+ if test "$WITH_MINGWIN" = "yes" || test "$COMEX" -ge "10"; then
AC_MSG_CHECKING([for instmsia.exe/instmsiw.exe])
if test -x ./external/msi/instmsia.exe -a -x ./external/msi/instmsiw.exe; then
AC_MSG_RESULT([found])