summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2012-04-20 12:53:02 +0200
committerLuboš Luňák <l.lunak@suse.cz>2012-04-23 19:17:41 +0200
commit0341d7b972e6efb5daac0c6ca38949fc35099b53 (patch)
tree2e574597fd32d0b4242b191914f0d30b1daee908 /configure.in
parentdb8df57acd601ed084bd0122683e1bd066a4f143 (diff)
more flexible --enable-symbols=<for>
the argument given now can - be 'all', meaning everything - start with -, meaning not to enable symbols for that item - end with /, meaning everything in that toplevel directory - be a target of the form targettype_name, e.g. Library_swui Note that there is no ordering and removal takes precedence.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 2bbcfdc0b5e6..82256ec18e62 100644
--- a/configure.in
+++ b/configure.in
@@ -612,8 +612,10 @@ AC_ARG_ENABLE(symbols,
[Include debugging symbols in output. WARNING - a complete build needs
8 Gb of space and takes much longer (enables -g compiler flag).
You can also use this switch as follows:
- --enable-symbols="tl svx" to enable symbols only for the specified
- gbuild-build libraries.])
+ --enable-symbols="all -sw/ -Library_sc" to enable symbols only for
+ the specified gbuild-build targets (all means everything, - prepended
+ means not to enable, / appended means everything in the directory,
+ there is no ordering and removal disabling takes precedence).])
[
Enabling symbols disables the stripping of the solver
(--disable-strip-solver).
@@ -3468,21 +3470,21 @@ dnl whether to include symbols into final build.
dnl ===================================================================
AC_MSG_CHECKING([whether to include symbols])
if test -n "$enable_symbols" -a "$enable_symbols" != "no"; then
+ ENABLE_SYMBOLS="TRUE"
if test "$enable_symbols" = "y" || test "$enable_symbols" = "yes"; then
- ENABLE_SYMBOLS="TRUE"
- ENABLE_SYMBOLS_ONLY=
+ ENABLE_SYMBOLS_FOR=all
+ AC_MSG_RESULT([yes])
else
- ENABLE_SYMBOLS=""
- ENABLE_SYMBOLS_ONLY="$enable_symbols"
+ ENABLE_SYMBOLS_FOR="$enable_symbols"
AC_MSG_RESULT([for $enable_symbols])
fi
else
ENABLE_SYMBOLS=
- ENABLE_SYMBOLS_ONLY=
+ ENABLE_SYMBOLS_FOR=
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_SYMBOLS)
-AC_SUBST(ENABLE_SYMBOLS_ONLY)
+AC_SUBST(ENABLE_SYMBOLS_FOR)
dnl Determine if the solver is to be stripped or not.
dnl ===================================================================