summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBjoern Michaelsen <bjoern.michaelsen@canonical.com>2012-04-16 00:42:28 +0200
committerBjoern Michaelsen <bjoern.michaelsen@canonical.com>2012-04-16 11:59:42 +0200
commitebed42c38ae91147633c47873307e07984bc62c1 (patch)
tree1a03eab7f4ba386f5fb75b8bfb23657b63155652 /configure.in
parent839a8250114dd0352048c4812b6fa71dc9b1c5b3 (diff)
introduce ENABLE_DEBUG_ONLY
with this you can now do: ./autogen.sh --enable-debug="sw sc" and your build will have debug version of the libraries sw and sc, but a non-debug build elsewhere. This currently only works for libraries. It would be also possible to extend that to excutables, but that would need explicit in the enable-debug switch then: ./autogen.sh --enable-debug="Library/sw Library/sc Executable/mkunroll" so I dont know if it is worth it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 01b86c285dbd..e75f81ce7e66 100644
--- a/configure.in
+++ b/configure.in
@@ -3426,15 +3426,22 @@ AC_SUBST(EXTERNAL_WARNINGS_NOT_ERRORS)
dnl Set the ENABLE_DEBUG variable. (Activate --enable-symbols)
dnl ===================================================================
AC_MSG_CHECKING([whether to do a debug build])
-if test -n "$enable_debug" -a "$enable_debug" != "no"; then
- ENABLE_DEBUG="TRUE"
- enable_symbols="yes"
- AC_MSG_RESULT([yes])
+if test -n "$enable_debug" && test "$enable_debug" != "no"; then
+ if test "$enable_debug" = "y" || test "$enable_debug" = "yes"; then
+ ENABLE_DEBUG="TRUE"
+ ENABLE_DEBUG_ONLY=
+ else
+ ENABLE_DEBUG=""
+ ENABLE_DEBUG_ONLY="$enable_debug"
+ AC_MSG_RESULT([for $enable_debug])
+ fi
else
ENABLE_DEBUG=""
+ ENABLE_DEBUG_ONLY=""
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_DEBUG)
+AC_SUBST(ENABLE_DEBUG_ONLY)
dnl Determine whether to use linkoo for the smoketest installation