summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mst@apache.org>2011-09-17 21:33:08 +0000
committerMichael Stahl <mst@apache.org>2011-09-17 21:33:08 +0000
commit352043cdf7642b7effd796a34ceed80a73630caf (patch)
tree2db52900644823925a91081a8d347ef1bc698324 /configure.in
parentefbbb7e22c7bf90d4b2f15eced6a2814bcd5450b (diff)
vcl340fixes: #i117804# differentiate between ENABLE_CAIRO and ENABLE_CAIRO_CANVAS
# HG changeset patch # User Philipp Lohmann [pl] <Philipp.Lohmann@Oracle.COM> # Date 1302633427 -7200 # Node ID 56bc1b624a3a49dcbf38a6b83266e89817752230 # Parent 217dd772a45a24b10e6e2f8b81b598c5034c7882
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0052aa63fcb2..5bd89ad54c40 100644
--- a/configure.in
+++ b/configure.in
@@ -209,6 +209,10 @@ AC_ARG_ENABLE(cairo,
AC_ARG_WITH(system-cairo,
[ --with-system-cairo Use Cairo libraries already on system
],,)
+AC_ARG_ENABLE(cairo-canvas,
+[ --disable-cairo-canvas Determines whether to build the Cairo canvas on
+ platforms where Cairo is available.
+],,enable_cairo_canvas=yes)
AC_ARG_ENABLE(librsvg,
[ --enable-librsvg Determines whether to use librsvg library on
platforms where librsvg is available.
@@ -5937,6 +5941,12 @@ AC_SUBST(SYSTEM_CAIRO)
AC_SUBST(CAIRO_CFLAGS)
AC_SUBST(CAIRO_LIBS)
+ENABLE_CAIRO_CANVAS="FALSE"
+if test "$enable_cairo_canvas" = "yes" -a "$ENABLE_CAIRO" = "TRUE" ; then
+ ENABLE_CAIRO_CANVAS="TRUE"
+fi
+AC_SUBST(ENABLE_CAIRO_CANVAS)
+
dnl ===================================================================
dnl Check whether the librsvg libraries are available.
dnl ===================================================================