summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPedro Giffuni <pfg@apache.org>2011-10-27 19:54:01 +0000
committerPedro Giffuni <pfg@apache.org>2011-10-27 19:54:01 +0000
commit76530e39db32c1d1694852da8b1430ccaaa25d9c (patch)
tree87aa41099f9ae9f2089450e871c6467e9dd266e3 /configure.in
parent98b2289ab92a5d747ac0779d20b5471d92bd4db5 (diff)
Disable legacy binfilter by default. Use --enable-binfilter in configure if you need them.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 29f7203951e1..6d746adf34c2 100644
--- a/configure.in
+++ b/configure.in
@@ -286,8 +286,8 @@ AC_ARG_ENABLE(kde4,
if you want to support both KDE3 and KDE4.
],,)
AC_ARG_ENABLE(binfilter,
-[ --disable-binfilter Disable legacy binary file formats filters
-],,if ! test -d ./binfilter; then enable_binfilter=no; fi)
+[ --enable-binfilter Enable legacy binary file formats filters
+],,)
AC_ARG_ENABLE(rpath,
[ --disable-rpath Disable the use of relative paths in shared libraries
],,)
@@ -1336,13 +1336,13 @@ dnl ===================================================================
dnl Disable legacy binary file formats filters
dnl ===================================================================
AC_MSG_CHECKING([whether to enable filters for legacy binary file formats (StarOffice 5.2)])
-if test "$enable_binfilter" = "no"; then
- WITH_BINFILTER="NO"
- AC_MSG_RESULT([no])
-else
+if test "$enable_binfilter" = "yes"; then
WITH_BINFILTER="YES"
BUILD_TYPE="$BUILD_TYPE BINFILTER"
AC_MSG_RESULT([yes])
+else
+ WITH_BINFILTER="NO"
+ AC_MSG_RESULT([no])
fi
AC_SUBST(WITH_BINFILTER)