summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJürgen Schmidt <jsc@apache.org>2011-09-30 09:29:06 +0000
committerJürgen Schmidt <jsc@apache.org>2011-09-30 09:29:06 +0000
commit8792fa02a60c006aa05cd2980b4bace8091f67d8 (patch)
treed2ca786c19ed1a48804b2a04e1b1c2340e34dd7c /configure.in
parent8874447204cb33d558b2c6dabcc514bcf948941e (diff)
118457: applied patch, remove instmsi deps, thanks to Oliver-Rainer Wittmann (orw)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 0 insertions, 35 deletions
diff --git a/configure.in b/configure.in
index 682e860dc8e6..92727f5d940d 100644
--- a/configure.in
+++ b/configure.in
@@ -5711,41 +5711,6 @@ You may have to search Microsoft's website. Last time it was seen at:
fi
dnl ===================================================================
-dnl Windows builds - attempt to auto-copy required instmsiX.exe into external/
-dnl ===================================================================
-if test "$_os" = "WINNT"; then
- ./oowintool --msvc-copy-instmsi ./external/msi
-fi
-
-dnl ===================================================================
-dnl Windows builds with VS 2003/2005/2008 need instmsia.exe and instmsiw.exe in external/msi
-dnl ===================================================================
-if test "$_os" = "WINNT"; then
- if test "$WITH_MINGWIN" = "yes" || test "$COMEX" -ge "10"; then
- AC_MSG_CHECKING([for instmsia.exe/instmsiw.exe])
- if test -x ./external/msi/instmsia.exe -a -x ./external/msi/instmsiw.exe; then
- AC_MSG_RESULT([found])
- else
- MSIAPATH=`/bin/find "$COMPATH/.." -iname instmsia.exe | head -n 1`
- MSIWPATH=`/bin/find "$COMPATH/.." -iname instmsiw.exe | head -n 1`
- if test -n "$MSIAPATH" -a -n "$MSIWPATH"; then
- cp "$MSIAPATH" ./external/msi/ && chmod +x ./external/msi/instmsia.exe && MSIACOPY="OK"
- cp "$MSIWPATH" ./external/msi/ && chmod +x ./external/msi/instmsiw.exe && MSIWCOPY="OK"
- fi
- if test -z "$MSIACOPY" -o -z "$MSIWCOPY"; then
- AC_MSG_ERROR([instmsia.exe and/or instmsiw.exe are/is missing in the default location.
-These programs are part of the Visual Studio installation and should be found in a
-directory similar to:
-"c:\\Program Files\\Microsoft Visual Studio .NET 2003\\Common7\\Tools\\Deployment\\MsiRedist\\"
-As the automatic detection fails please copy the files to external/msi/.])
- else
- AC_MSG_RESULT([found and copied])
- fi
- fi
-fi
-fi
-
-dnl ===================================================================
dnl Test which vclplugs have to be built.
dnl ===================================================================
AC_MSG_CHECKING([which VCLplugs shall be built])