summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2011-06-02 14:17:11 +0300
committerTor Lillqvist <tml@iki.fi>2011-06-02 14:17:11 +0300
commit1000d15c859f7f1823704517c82ed0f3987a3e7b (patch)
treea36f83f3a396e5aefcb27de46326069965bd7f84 /configure.in
parent89b73e32fd7e0696acbf0510eb874c74a034e82e (diff)
Move PKG_PROG_PKG_CONFIG earlier, and don't duplicate it
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in18
1 files changed, 7 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index f1131a7e8657..2eca92c00f7b 100755
--- a/configure.in
+++ b/configure.in
@@ -2407,6 +2407,13 @@ AC_SUBST(MSPDB_PATH)
AC_SUBST(USE_MINGW)
AC_SUBST(SHOWINCLUDES_PREFIX)
+dnl ===================================================================
+dnl Check for pkg-config
+dnl ===================================================================
+if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
+ PKG_PROG_PKG_CONFIG
+fi
+
if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
# If you use CC=/path/to/compiler/foo-gcc or even CC="ccache
@@ -2416,7 +2423,6 @@ if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
AC_CHECK_TOOL(AR,ar)
AC_CHECK_TOOL(NM,nm)
AC_CHECK_TOOL(OBJDUMP,objdump)
- AC_PATH_TOOL(PKG_CONFIG,pkg-config)
AC_CHECK_TOOL(RANLIB,ranlib)
AC_CHECK_TOOL(STRIP,strip)
if test "$_os" = "WINNT"; then
@@ -4031,16 +4037,6 @@ fi
AC_SUBST(GPERF)
dnl ===================================================================
-dnl Check for pkg-config
-dnl # Note that if there is a possibility the first call to
-dnl # PKG_CHECK_MODULES might not happen, you should be sure to include an
-dnl # explicit call to PKG_PROG_PKG_CONFIG in your configure.ac
-dnl ===================================================================
-if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
- PKG_PROG_PKG_CONFIG
-fi
-
-dnl ===================================================================
dnl Check for building stax
dnl ===================================================================
AC_MSG_CHECKING([whether to build the stax])