summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPedro Giffuni <pfg@apache.org>2011-11-21 02:09:49 +0000
committerPedro Giffuni <pfg@apache.org>2011-11-21 02:09:49 +0000
commit6934954fb243a22698e800b7051d7090a711082d (patch)
tree088cf3178de2e402a8e1143a82899c9ec4506fee /configure.in
parent26b698ff05bb36bd39ce4c1c1e4adb8b6baaaeba (diff)
Revert r1190021: make sure that binfilter will be built by default for the next release.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index de6727a7af58..3655b2fe40b6 100644
--- a/configure.in
+++ b/configure.in
@@ -272,8 +272,8 @@ AC_ARG_ENABLE(kde4,
if you want to support both KDE3 and KDE4.
],,)
AC_ARG_ENABLE(binfilter,
-[ --enable-binfilter Enable legacy binary file formats filters
-],,)
+[ --disable-binfilter Disable legacy binary file formats filters
+],,if ! test -d ./binfilter; then enable_binfilter=no; fi)
AC_ARG_ENABLE(rpath,
[ --disable-rpath Disable the use of relative paths in shared libraries
],,)
@@ -1299,13 +1299,13 @@ dnl ===================================================================
dnl Disable legacy binary file formats filters
dnl ===================================================================
AC_MSG_CHECKING([whether to enable filters for legacy binary file formats (StarOffice 5.2)])
-if test "$enable_binfilter" = "yes"; then
+if test "$enable_binfilter" = "no"; then
+ WITH_BINFILTER="NO"
+ AC_MSG_RESULT([no])
+else
WITH_BINFILTER="YES"
BUILD_TYPE="$BUILD_TYPE BINFILTER"
AC_MSG_RESULT([yes])
-else
- WITH_BINFILTER="NO"
- AC_MSG_RESULT([no])
fi
AC_SUBST(WITH_BINFILTER)