summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2011-06-02 14:04:59 +0300
committerTor Lillqvist <tml@iki.fi>2011-06-02 14:05:06 +0300
commit89b73e32fd7e0696acbf0510eb874c74a034e82e (patch)
treedd82ef0c01c0c37833d1cd44f08ed4936fc12395 /configure.in
parent4b93f8cdc7283e00fdeaf7151f49df6436c89b6e (diff)
Explicitly ignore potential unwanted pkg-config found on Mac OS X
We want to be buildable on Mac OS X without pkg-config. For instance Mono installs a symlink /usr/bin/pkg-config that just confuses this goal if you happen to build LibreOffice on a machine with Mono installed.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index efaa8de4f54c..f1131a7e8657 100755
--- a/configure.in
+++ b/configure.in
@@ -2416,7 +2416,7 @@ if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
AC_CHECK_TOOL(AR,ar)
AC_CHECK_TOOL(NM,nm)
AC_CHECK_TOOL(OBJDUMP,objdump)
- AC_CHECK_TOOL(PKG_CONFIG,pkg-config)
+ AC_PATH_TOOL(PKG_CONFIG,pkg-config)
AC_CHECK_TOOL(RANLIB,ranlib)
AC_CHECK_TOOL(STRIP,strip)
if test "$_os" = "WINNT"; then
@@ -2434,6 +2434,25 @@ AC_SUBST(STRIP)
AC_SUBST(WINDRES)
dnl ===================================================================
+dnl pkg-config checks on Mac OS X
+dnl ===================================================================
+
+if test $_os = Darwin; then
+ AC_MSG_CHECKING([for bogus pkg-config])
+ if test -n "$PKG_CONFIG"; then
+ if test "$PKG_CONFIG" = /usr/bin/pkg-config && ls -l /usr/bin/pkg-config | grep -q Mono.framework; then
+ AC_MSG_RESULT([yes, from Mono, ignoring])
+ PKG_CONFIG=""
+ else
+ AC_MSG_RESULT([yes, from unknown origin, ignoring])
+ PKG_CONFIG=""
+ fi
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+
+dnl ===================================================================
dnl .NET needs special treatment
dnl (does the above comment really mean .NET, or is it misusing
dnl that to mean Visual Studio .NET 2003 ? And does this also