summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKohei Yoshida <kohei.yoshida@gmail.com>2012-07-27 22:14:39 -0400
committerKohei Yoshida <kohei.yoshida@gmail.com>2012-09-07 09:10:34 -0400
commita6639312005763d19e877bc61e6a844c09f5fb23 (patch)
treea955fe459e1eb82957100dd1c397ee3a31c32fdd /configure.in
parent948350d60c031904c7daffc7be95ef9c146e700c (diff)
First cut on integrating liborcus into libreoffice tree....
It introduces the 'FilterProvider' property in the media descriptor to optionally bypass the normal loading process and let the external filter provider to handle the loading. For now I'm overwriting the csv import filter just to see how this could work just as an experiment. Orcus still needs a lot of work, and it crashes very often at the moment. Change-Id: I11b34572c71073144804a7d0dd5176c8067d8deb
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 28 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index c5a9357de4a0..f22a493d0ef6 100644
--- a/configure.in
+++ b/configure.in
@@ -1637,6 +1637,11 @@ AC_ARG_WITH(system-redland,
[Use redland library already on system.]),,
[with_system_redland="$with_system_libs"])
+AC_ARG_WITH(system-orcus,
+ AS_HELP_STRING([--with-system-orcus],
+ [Use orcus library already on system.]),,
+ [with_system_orcus="$with_system_libs"])
+
AC_ARG_WITH(system-mozilla,
AS_HELP_STRING([--with-system-mozilla],
[Use Mozilla already on system. Note that some components cannot be built
@@ -4837,7 +4842,7 @@ _ACEOF
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
#include <iostream>
using namespace std;
-]], [[ try { throw 42; } catch (int e) { cout << "Yep, " << e << endl; } ]])],[
+]], [[ try { throw 42; } catch (int e) { cout << "Yep, " << e << endl; } ]])],[
MINGW_GCCDLL=`$OBJDUMP -p conftest.exe | grep 'DLL Name: libgcc' | $SED -e 's@.*DLL Name: @@'`
if test -n "$MINGW_GCCDLL"; then
MINGW_SHARED_GCCLIB=YES
@@ -4847,14 +4852,14 @@ using namespace std;
AC_MSG_RESULT([no])
fi
],[ AC_MSG_RESULT([no])
-
+
])
AC_MSG_CHECKING([for dynamic libstdc++])
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
#include <iostream>
using namespace std;
-]], [[ cout << "Hello there." << endl; ]])],[
+]], [[ cout << "Hello there." << endl; ]])],[
MINGW_GXXDLL=`$OBJDUMP -p conftest.exe | grep 'DLL Name: libstdc++' | $SED -e 's@.*DLL Name: @@'`
if test -n "$MINGW_GXXDLL"; then
mingw_gxxdll_root=${MINGW_GXXDLL%.dll}
@@ -4871,7 +4876,7 @@ using namespace std;
AC_MSG_RESULT([no])
fi
],[ AC_MSG_RESULT([no])
-
+
])
AC_LANG_POP([C++])
@@ -8589,6 +8594,25 @@ AC_SUBST([MINGW_REDLAND_DLL])
AC_SUBST([MINGW_SQLITE3_DLL])
dnl ===================================================================
+dnl Check for system orcus
+dnl ===================================================================
+AC_MSG_CHECKING([which orcus library to use])
+if test "$with_system_orcus" = "yes"; then
+ AC_MSG_RESULT([external])
+ SYSTEM_ORCUS=YES
+ ORCUS_CFLAGS="`$PKG_CONFIG --cflags liborcus-0.2`"
+ ORCUS_LIBS="`$PKG_CONFIG --libs liborcus-0.2`"
+ PKG_CHECK_MODULES(ORCUS, orcus >= 0.1.0)
+else
+ AC_MSG_RESULT([internal])
+ BUILD_TYPE="$BUILD_TYPE ORCUS"
+ SYSTEM_ORCUS=NO
+fi
+AC_SUBST(SYSTEM_ORCUS)
+AC_SUBST(ORCUS_CFLAGS)
+AC_SUBST(ORCUS_LIBS)
+
+dnl ===================================================================
dnl Check for system hunspell
dnl ===================================================================
AC_MSG_CHECKING([which libhunspell to use])