summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2011-07-22 11:27:13 +0100
committerCaolán McNamara <caolanm@redhat.com>2011-07-22 11:28:03 +0100
commitd1f6403c9ee3caf6b2e6babe5eb6b2ff62feaa9d (patch)
tree16be5479dc7b0f05c352ee312923e374370f4efe /configure.in
parent8b857bd5b0548d0d15e3146b116d639c4dd08dbd (diff)
ENABLE_DEBUG_STL isn't working out for us, too easy to mix with and without
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index fa6ef65e3bbf..0258e63290cc 100755
--- a/configure.in
+++ b/configure.in
@@ -1876,16 +1876,13 @@ dnl ===================================================================
AC_MSG_CHECKING([whether to do a debug build])
if test -n "$enable_debug" && test "$enable_debug" != "no"; then
ENABLE_DEBUG="TRUE"
- ENABLE_DEBUG_STL="TRUE"
enable_symbols="yes"
AC_MSG_RESULT([yes])
else
ENABLE_DEBUG="FALSE"
- ENABLE_DEBUG_STL="FALSE"
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_DEBUG)
-AC_SUBST(ENABLE_DEBUG_STL)
dnl Set the ENABLE_DBGUTIL variable
dnl ===================================================================
@@ -4238,17 +4235,7 @@ dnl ===================================================================
dnl Check for system cppunit
dnl ===================================================================
AC_MSG_CHECKING([which cppunit to use])
-if test -z "$ENABLE_DEBUG_STL"; then
- AC_MSG_ERROR([Internal error, debug build check needs to precede cppunit check])
-fi
-if test "$ENABLE_DEBUG_STL" = "TRUE"; then
- if test "$with_system_cppunit" = "yes"; then
- AC_MSG_ERROR([--with-system-cppunit conflicts with debug build])
- fi
- AC_MSG_RESULT([internal, needed by debug build])
- SYSTEM_CPPUNIT=NO
- BUILD_TYPE="$BUILD_TYPE CPPUNIT"
-elif test -n "$with_system_cppunit" -o -n "$with_system_libs" && \
+if test -n "$with_system_cppunit" -o -n "$with_system_libs" && \
test "$with_system_cppunit" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_CPPUNIT=YES