summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@suse.cz>2011-07-25 13:16:22 +0200
committerJan Holesovsky <kendy@suse.cz>2011-07-25 13:16:22 +0200
commitd78bb867f4ded5584bba8ce0ec46fcef14b91773 (patch)
treeaba6ab9ed2b114096df25014c5751e07d7f63043 /configure.in
parent276ba69ad234dde1378c3c36bf95db66aaeba133 (diff)
Make the zip error message less confusing.
[Report directly when checking for zip, not after checking for unzip.]
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 417c44558b48..b119a6718433 100755
--- a/configure.in
+++ b/configure.in
@@ -6283,12 +6283,13 @@ dnl We need zip and unzip
dnl ===================================================================
AC_PATH_PROG(ZIP, zip)
test -z "$ZIP" && AC_MSG_ERROR([zip is required])
-AC_PATH_PROG(UNZIP, unzip)
-test -z "$UNZIP" && AC_MSG_ERROR([unzip is required])
if "$ZIP" -FS < /dev/null 2>&1 | $EGREP "no such option: S" > /dev/null; then
AC_MSG_ERROR([Zip version 3.0 or newer is required to build, please install or use --with-zip-home],,)
fi
+AC_PATH_PROG(UNZIP, unzip)
+test -z "$UNZIP" && AC_MSG_ERROR([unzip is required])
+
dnl ===================================================================
dnl Zip must be a specific type for different build types.
dnl ===================================================================