summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoseph Powers <jpowers27@cox.net>2011-07-28 22:20:09 -0700
committerJoseph Powers <jpowers27@cox.net>2011-07-28 22:20:09 -0700
commitea20700440ec59a0cf56562be76478e99feb8d68 (patch)
tree7b18b2bbc4950291b839133256d12634079bba3c /configure.in
parent791fa6dc9b218aacc4e58884954758718ee26715 (diff)
Mac OS 10.7: Installing xCode 4.1 renames 3.6.2 to /Developer-old
xCode 4.1 only ships with SDKs 10.6 & 10.7; thus, if the request 10.4 or 10.5 doesn't exists, try looking in /Developer-old.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7b9713476658..f54b1e905d85 100755
--- a/configure.in
+++ b/configure.in
@@ -1740,10 +1740,16 @@ if test "$_os" = "Darwin" ; then
10.4)
MACOSX_SDK_PATH="/Developer/SDKs/MacOSX10.4u.sdk"
+ if ! [ test -d "$MACOSX_SDK_PATH" ]; then
+ MACOSX_SDK_PATH="/Developer-old/SDKs/MacOSX10.4u.sdk"
+ fi
macosx_sdk_value="1040"
;;
10.5)
MACOSX_SDK_PATH="/Developer/SDKs/MacOSX10.5.sdk"
+ if ! [ test -d "$MACOSX_SDK_PATH" ] ; then
+ MACOSX_SDK_PATH="/Developer-old/SDKs/MacOSX10.5.sdk"
+ fi
macosx_sdk_value="1050"
AC_MSG_WARN([Building with a SDK > 10.4 is experimental])
echo "Building with a SDK > 10.4 is experimental" >> warn