summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2011-07-18 14:31:00 +0200
committerLuboš Luňák <l.lunak@suse.cz>2011-07-18 14:31:30 +0200
commitf320e7ce8a86156e7ed46c3edaf12cc1be1618e1 (patch)
tree64b48d984cc8fc95f7c98314e9b68152bd22623f /configure.in
parent907535edb8db32935b555bb0d9e2f91d6cdb1e33 (diff)
use internal cppunit with STL debug enabled
http://lists.freedesktop.org/archives/libreoffice/2011-July/014970.html
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 88f09bbddc1e..fa6ef65e3bbf 100755
--- a/configure.in
+++ b/configure.in
@@ -4238,7 +4238,17 @@ dnl ===================================================================
dnl Check for system cppunit
dnl ===================================================================
AC_MSG_CHECKING([which cppunit to use])
-if test -n "$with_system_cppunit" -o -n "$with_system_libs" && \
+if test -z "$ENABLE_DEBUG_STL"; then
+ AC_MSG_ERROR([Internal error, debug build check needs to precede cppunit check])
+fi
+if test "$ENABLE_DEBUG_STL" = "TRUE"; then
+ if test "$with_system_cppunit" = "yes"; then
+ AC_MSG_ERROR([--with-system-cppunit conflicts with debug build])
+ fi
+ AC_MSG_RESULT([internal, needed by debug build])
+ SYSTEM_CPPUNIT=NO
+ BUILD_TYPE="$BUILD_TYPE CPPUNIT"
+elif test -n "$with_system_cppunit" -o -n "$with_system_libs" && \
test "$with_system_cppunit" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_CPPUNIT=YES