summaryrefslogtreecommitdiff
path: root/dmake/Makefile.am
diff options
context:
space:
mode:
authorJens-Heiner Rechtien <hr@openoffice.org>2006-04-20 10:56:21 +0000
committerJens-Heiner Rechtien <hr@openoffice.org>2006-04-20 10:56:21 +0000
commit219f5a2090873c55ad90ed91f38e9cff7b401313 (patch)
tree894bab9741c1030420b14a7b478e95b13ffaf366 /dmake/Makefile.am
parentb0317b7bccfdd3917b6b5c4634e4aa69ed98212e (diff)
INTEGRATION: CWS dmake43p01 (1.8.20); FILE MERGED
2005/09/26 00:33:11 vq 1.8.20.4: #i55070# Fix Fred Fishes DBUG macros and add --enable-dbug to enable them in a configure type build. Also regenerate autotool files. 2005/09/17 19:47:45 vq 1.8.20.3: RESYNC: (1.8-1.9); FILE MERGED 2005/06/02 03:41:17 vq 1.8.20.2: #i39248# Add testsuite for dmake (only tor targets using the autotools). 2005/05/05 23:06:05 vq 1.8.20.1: #i47851# Fix dependency checking for subdirectories.
Diffstat (limited to 'dmake/Makefile.am')
-rwxr-xr-xdmake/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/dmake/Makefile.am b/dmake/Makefile.am
index d4a721ae7260..8513879f781c 100755
--- a/dmake/Makefile.am
+++ b/dmake/Makefile.am
@@ -4,9 +4,9 @@
#
# $RCSfile: Makefile.am,v $
#
-# $Revision: 1.9 $
+# $Revision: 1.10 $
#
-# last change: $Author: rt $ $Date: 2005-09-08 17:59:52 $
+# last change: $Author: hr $ $Date: 2006-04-20 11:56:21 $
#
# The Contents of this file are made available subject to
# the terms of GNU Lesser General Public License Version 2.1.
@@ -43,15 +43,19 @@ dmake_SOURCES = \
infer.c make.c stat.c expand.c dmstring.c hash.c dag.c dmake.c\
path.c imacs.c sysintf.c parse.c getinp.c quit.c state.c\
dmdump.c macparse.c rulparse.c percent.c function.c
+if DBUG
+dmake_SOURCES += dbug/dbug/dbug.c
+endif
#dmake_LDADD = unix/libunix.a
#dmake_LDADD = win95/libwin95.a msdos/libmsdos.a win95/microsft/libmsft.a
-dmake_LDADD = $(OS_LIBRARY)
+dmake_LDADD = @OS_LIBRARY@
+dmake_DEPENDENCIES = @OS_LIBRARY@
-DIST_SUBDIRS = unix startup win95 msdos
-SUBDIRS = $(OS_SUBDIRS)
+DIST_SUBDIRS = unix startup win95 msdos tests
+SUBDIRS = $(OS_SUBDIRS) tests
-EXTRA_DIST = make.c
+EXTRA_DIST = NEWS ChangeLog
# set the include path found by configure
INCLUDES = -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/@OS_TYPE@/@OS_VERSION@ -I$(top_srcdir)/@OS_TYPE@ -I$(top_srcdir)/@OS_TYPE@/@OS_VERSION@/gnu