summaryrefslogtreecommitdiff
path: root/dmake/configure.in
diff options
context:
space:
mode:
authorMartin Hollmichel <mh@openoffice.org>2001-06-13 12:34:06 +0000
committerMartin Hollmichel <mh@openoffice.org>2001-06-13 12:34:06 +0000
commit47b5dc877c5bd9cd8241534a8b6d6a2ed16da7ce (patch)
tree6e556bdceab25c667850c73805f6e91542ed2f93 /dmake/configure.in
parent28004ba2af44afb28e78a2a00366f8c3fa53d105 (diff)
add: OS_VERSION to differ the Unix's
Diffstat (limited to 'dmake/configure.in')
-rwxr-xr-xdmake/configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/dmake/configure.in b/dmake/configure.in
index 4644b77182ff..875bdd21ad65 100755
--- a/dmake/configure.in
+++ b/dmake/configure.in
@@ -28,6 +28,7 @@ dnl Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/file.h sys/time.h unistd.h)
+AC_CONFIG_HEADERS(config.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -42,8 +43,20 @@ AC_FUNC_UTIME_NULL
AC_FUNC_VPRINTF
AC_CHECK_FUNCS(getcwd getwd putenv strcspn strerror strspn strstr)
+dnl Checks for OS
+OS_UNAME=`uname`
+if test ${OS_UNAME} = SunOS; then
+ echo "Solaris found"
+ OS_VERSION=solaris
+fi
+if test ${OS_UNAME} = Linux; then
+ echo "Linux found"
+ OS_VERSION=linux
+fi
+AC_SUBST(OS_VERSION)
+
AC_OUTPUT(Makefile unix/Makefile startup/Makefile startup/unix/Makefile \
- startup/unix/linux/Makefile dmakeroot.h )
+ startup/unix/linux/Makefile startup/unix/solaris/Makefile dmakeroot.h )
#AC_OUTPUT(unix/bsd43/Makefile Makefile makefile unix/solaris/Makefile dbug/malloc/makefile unix/Makefile)
dnl ******************************
@@ -52,6 +65,7 @@ dnl ******************************
AC_OUTPUT_COMMANDS([
+
## Generate `dmakeroot.h' in two cases
## 1. `config.status' is run either explicitly, or via configure.
## Esp. not when it is run in `Makefile' to generate makefiles and
@@ -85,6 +99,8 @@ if cmp -s $outfile dmakeroot.h; then
else
mv $outfile dmakeroot.h
fi
+],[
+OS_VERSION=$OS_VERSION
])