summaryrefslogtreecommitdiff
path: root/dmake/configure.in
diff options
context:
space:
mode:
authorKen Foskey <waratah@openoffice.org>2002-10-04 12:31:37 +0000
committerKen Foskey <waratah@openoffice.org>2002-10-04 12:31:37 +0000
commitc52e65d4c790b252c7c03dcc34312e47dc95fcda (patch)
tree547257810159a2791753d8d99ce5b87fc53dbd9b /dmake/configure.in
parenta89a994d774f348527f5dc2d68ebbeb870bf3e4a (diff)
Dmake: Convert the configure to a better configure process without individual conf.h files for every platform
Diffstat (limited to 'dmake/configure.in')
-rwxr-xr-xdmake/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/dmake/configure.in b/dmake/configure.in
index 182cf81dc543..48fc8d80ed7e 100755
--- a/dmake/configure.in
+++ b/dmake/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.13)
-AC_INIT(acconfig.h)
+AC_INIT
dnl set the DMAKEROOT
#AC_FUNC_SET_DMAKEROOT
@@ -31,7 +31,7 @@ dnl Initialize libtool
dnl Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
-AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/file.h sys/time.h unistd.h)
+AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/types.h sys/stat.h unistd.h errno.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -72,7 +72,7 @@ case "$_os" in
OS_VERSION=linux
;;
"OSF1")
- OS_VERSION=tru64
+ OS_VERSION=sysvr4
;;
"NetBSD")
OS_VERSION=linux
@@ -93,6 +93,8 @@ AC_MSG_RESULT([checked ($_os)])
AC_SUBST(OS_VERSION)
+AM_CONFIG_HEADER(config.h)
+
AC_OUTPUT(Makefile unix/Makefile startup/Makefile startup/unix/Makefile \
startup/unix/linux/Makefile startup/unix/solaris/Makefile \
startup/unix/macosx/Makefile dmakeroot.h )