summaryrefslogtreecommitdiff
path: root/dmake/configure.in
diff options
context:
space:
mode:
authorMartin Hollmichel <mh@openoffice.org>2002-03-26 13:23:19 +0000
committerMartin Hollmichel <mh@openoffice.org>2002-03-26 13:23:19 +0000
commit618f89696143f99cc7ae865076607b8e70dfd1c1 (patch)
tree3d37abbe18adb4c20153a637202ff3606a59d3a2 /dmake/configure.in
parent17ec3915013a07837ab5d646144da95148ad2ec7 (diff)
add: cygwin
Diffstat (limited to 'dmake/configure.in')
-rwxr-xr-xdmake/configure.in41
1 files changed, 25 insertions, 16 deletions
diff --git a/dmake/configure.in b/dmake/configure.in
index 95ad4523061b..257eae8a8ccf 100755
--- a/dmake/configure.in
+++ b/dmake/configure.in
@@ -44,22 +44,31 @@ AC_CHECK_FUNCS(getcwd getwd putenv strcspn strerror strspn strstr)
dnl Checks for OS
OS_UNAME=`uname`
-if test ${OS_UNAME} = SunOS; then
- echo "Solaris found"
- OS_VERSION=solaris
-fi
-if test ${OS_UNAME} = Linux; then
- echo "Linux found"
- OS_VERSION=linux
-fi
-if test ${OS_UNAME} = Irix; then
- echo "Irix found"
- OS_VERSION=sysvr4
-fi
-if test ${OS_UNAME} = FreeBSD; then
- echo "FreeBSD found"
- OS_VERSION=386ix
-fi
+case $OS_UNAME in
+ SunOS)
+ OS_VERSION=solaris
+ echo "Solaris found"
+ ;;
+ Linux)
+ OS_VERSION=linux
+ echo "Linux found"
+ ;;
+ Irix)
+ OS_VERSION=sysvr4
+ echo "Irix found"
+ ;;
+ FreeBsd)
+ OS_VERSION=386ix
+ echo "FreeBSD found"
+ ;;
+ CYGWIN* | cygwin* | mingw*)
+ OS_VERSION=cygwin
+ echo "cygwin found"
+ ;;
+ *)
+ echo "Unknown OS"
+ ;;
+esac
AC_SUBST(OS_VERSION)
AC_OUTPUT(Makefile unix/Makefile startup/Makefile startup/unix/Makefile \