summaryrefslogtreecommitdiff
path: root/sysui/desktop/freedesktop/freedesktop-menus.spec
diff options
context:
space:
mode:
authorRüdiger Timm <rt@openoffice.org>2006-02-06 15:39:44 +0000
committerRüdiger Timm <rt@openoffice.org>2006-02-06 15:39:44 +0000
commit84d2e75e4b3b46d8d320269b9d26b0b286768778 (patch)
tree2f4acd9ec5d9848538c091306eafe758a843dec3 /sysui/desktop/freedesktop/freedesktop-menus.spec
parent1d85fe3cb9eb0ee734d817ef9ed7bc0911dcf248 (diff)
INTEGRATION: CWS cloph02 (1.12.22); FILE MERGED
2006/01/14 01:32:33 cloph 1.12.22.2: Issue number: #i57871# Submitted by: cloph Don't assume the script can find the binary to update the icon-cache.. Check for existence of the cache, then touch the theme-dir to invalidate the cache and then try to update the cache. 2005/12/12 19:27:08 cloph 1.12.22.1: Issue number: #i57871# Submitted by: cloph
Diffstat (limited to 'sysui/desktop/freedesktop/freedesktop-menus.spec')
-rw-r--r--sysui/desktop/freedesktop/freedesktop-menus.spec22
1 files changed, 22 insertions, 0 deletions
diff --git a/sysui/desktop/freedesktop/freedesktop-menus.spec b/sysui/desktop/freedesktop/freedesktop-menus.spec
index 7eba57277305..4b7b5d56dbd3 100644
--- a/sysui/desktop/freedesktop/freedesktop-menus.spec
+++ b/sysui/desktop/freedesktop/freedesktop-menus.spec
@@ -125,6 +125,17 @@ if [ "$1" = "1" ] ; then # first install
if (which update-mime-database); then
update-mime-database /usr/share/mime
fi
+ for theme in gnome hicolor locolor; do
+ if [ -e /usr/share/icons/$theme/icon-theme.cache ] ; then
+ # touch it, just in case we cannot find the binary...
+ touch /usr/share/icons/$theme
+ if (which gtk-update-icon-cache); then
+ gtk-update-icon-cache /usr/share/icons/$theme
+ fi
+ # ignore errors (e.g. when there is a cache, but no index.theme)
+ true
+ fi
+ done
fi
# update /etc/mime.types
@@ -266,6 +277,17 @@ fi
if (which update-mime-database); then
update-mime-database /usr/share/mime
fi
+for theme in gnome hicolor locolor; do
+ if [ -e /usr/share/icons/$theme/icon-theme.cache ] ; then
+ # touch it, just in case we cannot find the binary...
+ touch /usr/share/icons/$theme
+ if (which gtk-update-icon-cache); then
+ gtk-update-icon-cache /usr/share/icons/$theme
+ fi
+ # ignore errors (e.g. when there is a cache, but no index.theme)
+ true
+ fi
+done
%files
# specify stale symlinks verbatim, not as glob - a change in recent versions of