summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a9edea108216..2bd85d5f72d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -294,6 +294,9 @@ AC_ARG_WITH(android-sdk,
,)
ANDROID_NDK_HOME=
+if test -z "$with_android_ndk" -a -e "$SRC_ROOT/external/android-ndk"; then
+ with_android_ndk="$SRC_ROOT/external/android-ndk"
+fi
if test -n "$with_android_ndk"; then
ANDROID_NDK_HOME=$with_android_ndk
@@ -760,7 +763,7 @@ linux-android*)
_os=Android
if test -z "$with_android_ndk"; then
- AC_MSG_ERROR([the --with-android-ndk option is mandatory])
+ AC_MSG_ERROR([the --with-android-ndk option is mandatory, unless it is available at external/android-ndk/.])
fi
if test -z "$with_android_ndk_toolchain_version"; then