summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cecc4993641f..a21c8ec9bc60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2398,7 +2398,7 @@ AC_ARG_WITH(system-liblangtag,
AC_ARG_WITH(webdav,
AS_HELP_STRING([--with-webdav],
[Specify which library to use for webdav implementation.
- Possible values: "neon", "serf", "no". The default value is "neon".
+ Possible values: "neon", "serf", "curl", "no". The default value is "neon".
Example: --with-webdav="serf"]))
AC_ARG_WITH(linker-hash-style,
@@ -10873,6 +10873,13 @@ fi
AC_MSG_CHECKING([for webdav library])
case "$WITH_WEBDAV" in
+curl)
+ AC_MSG_RESULT([curl])
+ # curl is already mandatory (almost) and checked elsewhere
+ if test "$enable_curl" = "no"; then
+ AC_MSG_ERROR(["--with-webdav=curl conflicts with --disable-curl"])
+ fi
+ ;;
serf)
AC_MSG_RESULT([serf])
# Check for system apr-util