summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 3 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index e969fbfd68d3..7964508a55f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1096,10 +1096,6 @@ AC_ARG_ENABLE(cairo-canvas,
platforms where Cairo is available.
])
-AC_ARG_ENABLE(opencl,
- AS_HELP_STRING([--disable-opencl],
- [Determines whether to build with OpenCL support.]))
-
AC_ARG_ENABLE(dbus,
AS_HELP_STRING([--disable-dbus],
[Determines whether to enable features that depend on dbus.
@@ -10267,21 +10263,12 @@ dnl =================================================
dnl Check whether to build with OpenCL support.
dnl =================================================
-AC_MSG_CHECKING([whether to build with the OpenCL support.])
-ENABLE_OPENCL=
-
-if test $_os != iOS -a $_os != Android -a "x$enable_opencl" != "xno"; then
- AC_MSG_RESULT([yes])
- # CLCC in BUILD_TYPE tells that we are building a bundled clcc (just the clew part), OPENCL in
- # BUILD_TYPE tells that OpenCL is potentially available on the platform (optional at run-time,
+if test $_os != iOS -a $_os != Android; then
+ # OPENCL in BUILD_TYPE tells that OpenCL is potentially available on the platform (optional at run-time,
# used through clew).
- BUILD_TYPE="$BUILD_TYPE CLCC OPENCL"
- ENABLE_OPENCL=TRUE
+ BUILD_TYPE="$BUILD_TYPE OPENCL"
AC_DEFINE(HAVE_FEATURE_OPENCL)
-else
- AC_MSG_RESULT([no])
fi
-AC_SUBST(ENABLE_OPENCL)
dnl ===================================================================
dnl Check whether to enable glTF support