summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 320384cabc35..63e14794c022 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11829,7 +11829,11 @@ AC_MSG_CHECKING([which languages to be built])
# + removes en-US; we want to put it on the beginning
# + prints just the section starting with 'completelangiso=' and ending with the " at the end of line
[eval $(sed -e :a -e '/\\$/N; s/\\\n//; ta' -n -e 's/=/="/;s/\([^\\]\)$/\1"/;s/en-US//;/^completelangiso/p' $SRC_ROOT/solenv/inc/langlist.mk)]
-ALL_LANGS="en-US $completelangiso"
+if test "$enable_release_build" = "" -o "$enable_release_build" = "no"; then
+ ALL_LANGS="en-US $completelangiso qtz"
+else
+ ALL_LANGS="en-US $completelangiso"
+fi
# check the configured localizations
WITH_LANG="$with_lang"
if test -z "$WITH_LANG" -o "$WITH_LANG" = "en-US"; then
@@ -11853,10 +11857,11 @@ for lang in $WITH_LANG; do
done
# list with substituted ALL
WITH_LANG_LIST=`echo $WITH_LANG | sed "s/ALL/$ALL_LANGS/"`
-# this variable is used only by bin/distro-install-* helper scripts
-# they need a real list of languages
test -z "$WITH_LANG_LIST" && WITH_LANG_LIST="en-US"
test "$WITH_LANG" = "en-US" && WITH_LANG=
+if test "$enable_release_build" = "" -o "$enable_releasbie_build" = "no"; then
+ test "$WITH_LANG_LIST" = "en-US" || WITH_LANG_LIST=`echo $WITH_LANG_LIST qtz`
+fi
AC_SUBST(ALL_LANGS)
AC_SUBST(WITH_LANG)
AC_SUBST(WITH_LANG_LIST)