summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 298aa3c5f4ae..5c78dff5ee72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10512,12 +10512,18 @@ AC_SUBST(ENABLE_OPENCL)
dnl ===================================================================
dnl Check whether to enable glTF support
dnl ===================================================================
+AC_MSG_CHECKING([whether to enable glTF support])
+if test "$ENABLE_RELEASE_BUILD" = "TRUE"; then
+ if test $_os == iOS -o $_os == Android -o $_os = Darwin; then
+ enable_gltf=no
+ fi
+fi
ENABLE_GLTF=
-AC_MSG_CHECKING([whether to enable glTF support])
if test "x$enable_gltf" != "xno"; then
ENABLE_GLTF=TRUE
AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_FEATURE_GLTF,1)
BUILD_TYPE="$BUILD_TYPE LIBGLTF"
if test "$test_freetype" = "no"; then
BUILD_TYPE="$BUILD_TYPE FREETYPE"