summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 6086b4ca6b20..434972b51fe3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10516,25 +10516,12 @@ dnl ===================================================================
dnl Check whether to enable glTF support
dnl ===================================================================
AC_MSG_CHECKING([whether to enable glTF support])
-if test "$ENABLE_RELEASE_BUILD" = "TRUE"; then
- if test $_os == iOS -o $_os == Android -o $_os = Darwin; then
- enable_gltf=no
- fi
-fi
-
ENABLE_GLTF=
-if test "x$enable_gltf" != "xno"; then
+if test "x$enable_gltf" != "xno" -a $_os != Darwin -a $_os != iOS -a $_os != Android; then
ENABLE_GLTF=TRUE
AC_MSG_RESULT([yes])
AC_DEFINE(HAVE_FEATURE_GLTF,1)
BUILD_TYPE="$BUILD_TYPE LIBGLTF"
- if test "$test_freetype" = "no"; then
- BUILD_TYPE="$BUILD_TYPE FREETYPE"
- if test "$COM" = "MSC"; then
- test -n "${MSVC_USE_DEBUG_RUNTIME}" && FREETYPE_LIB_DEBUGLIB_SUFFIX="_D"
- FREETYPE_LIBS="${WORKDIR}/UnpackedTarball/freetype/objs/win32/vc2010/freetype248$FREETYPE_LIB_DEBUGLIB_SUFFIX.lib"
- fi
- fi
# otherwise build fails in collada2gltf external because of std::shared_ptr
if test "$have_std_shared_ptr" = "yes"; then
BUILD_TYPE="$BUILD_TYPE COLLADA2GLTF"