summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 10 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 62f0b0f339ca..731e9035bd08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1039,11 +1039,6 @@ AC_ARG_ENABLE(mergelibs,
for Linux any more. This will link a core set of libraries into libmerged.])
)
-AC_ARG_ENABLE(graphite,
- AS_HELP_STRING([--disable-graphite],
- [Disables the compilation of Graphite smart font rendering.])
-)
-
AC_ARG_ENABLE(breakpad,
AS_HELP_STRING([--enable-breakpad],
[Enables breakpad for crash reporting.])
@@ -4593,7 +4588,6 @@ if test "$cross_compiling" = "yes"; then
# Don't bother having configure look for stuff not needed for the build platform anyway
./configure \
--disable-cups \
- --disable-graphite \
--disable-gtk3 \
--disable-pdfimport \
--disable-postgresql-sdbc \
@@ -9183,29 +9177,6 @@ AC_SUBST(ICU_RECLASSIFIED_HEBREW_LETTER)
AC_SUBST(ICU_CFLAGS)
AC_SUBST(ICU_LIBS)
-dnl ===================================================================
-dnl Graphite
-dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([graphite],[GRAPHITE],[graphite2 >= 0.9.3],["-I${WORKDIR}/UnpackedTarball/graphite/include -DGRAPHITE2_STATIC"],["-L${WORKDIR}/LinkTarget/StaticLibrary -lgraphite"])
-if test "$with_system_graphite" = "yes"; then
- libo_MINGW_CHECK_DLL([libgraphite2])
-fi
-if test "$COM" = "MSC"; then # override the above
- GRAPHITE_LIBS="${WORKDIR}/LinkTarget/StaticLibrary/graphite.lib"
-fi
-
-# This is the old Graphite support that will eventually be removed
-AC_MSG_CHECKING([whether to enable graphite support])
-if test $_os != Darwin -a $_os != Android -a $_os != iOS -a \( -z "$enable_graphite" -o "$enable_graphite" != no \); then
- AC_MSG_RESULT([yes])
- ENABLE_GRAPHITE="TRUE"
- AC_DEFINE(ENABLE_GRAPHITE)
-
-else
- AC_MSG_RESULT([no])
-fi
-AC_SUBST(ENABLE_GRAPHITE)
-
dnl ==================================================================
dnl Breakpad
dnl ==================================================================
@@ -9281,10 +9252,19 @@ AC_SUBST(ENABLE_ORCUS)
dnl ===================================================================
dnl HarfBuzz
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18],["-I${WORKDIR}/UnpackedTarball/harfbuzz/src"],["-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz"])
+libo_CHECK_SYSTEM_MODULE([graphite],[GRAPHITE],[graphite2 >= 0.9.3],
+ ["-I${WORKDIR}/UnpackedTarball/graphite/include -DGRAPHITE2_STATIC"],
+ ["-L${WORKDIR}/LinkTarget/StaticLibrary -lgraphite"])
+
+libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18],
+ ["-I${WORKDIR}/UnpackedTarball/harfbuzz/src"],
+ ["-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz"])
+
if test "$COM" = "MSC"; then # override the above
+ GRAPHITE_LIBS="${WORKDIR}/LinkTarget/StaticLibrary/graphite.lib"
HARFBUZZ_LIBS="${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs/libharfbuzz.lib"
fi
+
if test "$with_system_harfbuzz" = "yes"; then
if test "$with_system_graphite" = "no"; then
AC_MSG_ERROR([--with-system-graphite must be used when --with-system-harfbuzz is used])
@@ -12877,7 +12857,6 @@ AC_CONFIG_HEADERS([config_host/config_firebird.h])
AC_CONFIG_HEADERS([config_host/config_folders.h])
AC_CONFIG_HEADERS([config_host/config_gio.h])
AC_CONFIG_HEADERS([config_host/config_global.h])
-AC_CONFIG_HEADERS([config_host/config_graphite.h])
AC_CONFIG_HEADERS([config_host/config_java.h])
AC_CONFIG_HEADERS([config_host/config_lgpl.h])
AC_CONFIG_HEADERS([config_host/config_liblangtag.h])