summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e6f9a7b0a2e3..b5149b922997 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,7 +169,13 @@ dnl ===================================================================
dnl Our version is defined by the AC_INIT() at the top of this script.
dnl ===================================================================
-set `echo AC_PACKAGE_VERSION | sed "s/\./ /g"`
+AC_MSG_CHECKING([for package version])
+if test -n "$with_package_version" -a "$with_package_version" != no; then
+ PACKAGE_VERSION="$with_package_version"
+fi
+AC_MSG_RESULT([$PACKAGE_VERSION])
+
+set `echo "$PACKAGE_VERSION" | sed "s/\./ /g"`
LIBO_VERSION_MAJOR=$1
LIBO_VERSION_MINOR=$2
@@ -1417,6 +1423,11 @@ AC_ARG_WITH(product-name,
[Define the product name. Default is AC_PACKAGE_NAME.]),
,with_product_name=$PRODUCTNAME)
+AC_ARG_WITH(package-version,
+ AS_HELP_STRING([--with-package-version='3.1.4.5'],
+ [Define the package version. Default is AC_PACKAGE_VERSION. Use only if you distribute an own build for macOS.]),
+,)
+
AC_ARG_ENABLE(ios-simulator,
AS_HELP_STRING([--enable-ios-simulator],
[Build for the iOS Simulator, not iOS device.]),