summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1051d20cf9a9..2329ae7bb6e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12347,6 +12347,10 @@ if echo "$host_os" | grep -q linux-android ; then
AC_MSG_RESULT([not set, using $ANDROID_PACKAGE_NAME])
else
+ if test -n "$ENABLE_DEBUG" -a "$with_android_package_name" != "org.libreoffice" ; then
+ AC_MSG_ERROR([The package name must be set
+to org.libreoffice when debugging, please avoid --with-android-package-name.])
+ fi
ANDROID_PACKAGE_NAME="$with_android_package_name"
AC_MSG_RESULT([$ANDROID_PACKAGE_NAME])
fi