summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 97e3f49efc9c..0b7415549198 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1526,6 +1526,11 @@ AC_ARG_ENABLE(ldap,
[Disable LDAP support.]),
,enable_ldap=yes)
+libo_FUZZ_ARG_ENABLE(librelogo,
+ AS_HELP_STRING([--disable-librelogo],
+ [Do not build LibreLogo.]),
+,enable_librelogo=yes)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -8815,6 +8820,23 @@ AC_SUBST(PYTHON_VERSION)
AC_SUBST(PYTHON_VERSION_MAJOR)
AC_SUBST(PYTHON_VERSION_MINOR)
+AC_MSG_CHECKING([whether to build LibreLogo])
+case "$enable_python" in
+no|disable)
+ AC_MSG_RESULT([no; Python disabled])
+ ;;
+*)
+ if test "${enable_librelogo}" = "no"; then
+ AC_MSG_RESULT([no])
+ else
+ AC_MSG_RESULT([yes])
+ BUILD_TYPE="${BUILD_TYPE} LIBRELOGO"
+ AC_DEFINE([ENABLE_LIBRELOGO],1)
+ fi
+ ;;
+esac
+AC_SUBST(ENABLE_LIBRELOGO)
+
ENABLE_MARIADBC=TRUE
if test "$_os" = "Android" -o "$_os" = "iOS" -o "$enable_mpl_subset" = "yes"; then
ENABLE_MARIADBC=