summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90a2d891cd21..e2f715bab268 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1271,6 +1271,17 @@ AC_ARG_WITH(package-format,
installed, msi. Example: --with-package-format="deb dmg"]),
,)
+AC_ARG_WITH(tls,
+ AS_HELP_STRING([--with-tls],
+ [Decides which TLS/SSL and cryptographic implementations to use for
+ LibreOffice's code. Notice that this doesn't apply for depending
+ libraries like "neon", for example. Default is to use OpenSSL
+ although NSS is also possible. Notice that selecting NSS restricts
+ the usage of OpenSSL in LO's code but selecting OpenSSL doesn't
+ restrict by now the usage of NSS in LO's code. Possible values:
+ openssl, nss. Example: --with-tls="nss"]),
+,)
+
AC_ARG_WITH(system-libs,
AS_HELP_STRING([--with-system-libs],
[Use libraries already on system -- enables all --with-system-* flags.]),
@@ -8092,6 +8103,34 @@ AC_SUBST(MSVC80_DLLS)
AC_SUBST(MSVC80_DLL_PATH)
dnl ===================================================================
+dnl Check for TLS/SSL and cryptographic implementation to use
+dnl ===================================================================
+AC_MSG_CHECKING([which TLS/SSL and cryptographic implementation to use])
+if test -n "$with_tls"; then
+ case $with_tls in
+ openssl)
+ AC_DEFINE(USE_TLS_OPENSSL)
+ TLS=OPENSSL
+ ;;
+ nss)
+ AC_DEFINE(USE_TLS_NSS)
+ TLS=NSS
+ ;;
+ *)
+ AC_MSG_ERROR([unsupported implementation $with_tls. Supported are:
+openssl - OpenSSL
+nss - Mozilla's Network Security Services (NSS)
+ ])
+ ;;
+ esac
+else
+ AC_DEFINE(USE_TLS_OPENSSL)
+ TLS=OPENSSL
+fi
+AC_MSG_RESULT([$TLS])
+AC_SUBST(TLS)
+
+dnl ===================================================================
dnl Check for system NSS
dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([nss],[NSS],[nss >= 3.9.3 nspr >= 4.8])
@@ -11805,6 +11844,7 @@ AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])
AC_CONFIG_HEADERS([config_host/config_kde4.h])
AC_CONFIG_HEADERS([config_host/config_mingw.h])
+AC_CONFIG_HEADERS([config_host/config_oox.h])
AC_CONFIG_HEADERS([config_host/config_telepathy.h])
AC_CONFIG_HEADERS([config_host/config_typesizes.h])
AC_CONFIG_HEADERS([config_host/config_vclplug.h])