summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e7ad75620e59..e86e3c30141d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1893,6 +1893,11 @@ AC_ARG_ENABLE(silent-msi,
[Enable MSI with LIMITUI=1 (silent install).]),
,)
+AC_ARG_ENABLE(wix,
+ AS_HELP_STRING([--enable-wix],
+ [Build Windows installer using WiX.]),
+,)
+
AC_ARG_ENABLE(macosx-code-signing,
AS_HELP_STRING([--enable-macosx-code-signing=<identity>],
[Sign executables, dylibs, frameworks and the app bundle. If you
@@ -13427,6 +13432,21 @@ else
fi
AC_SUBST(ENABLE_SILENT_MSI)
+dnl ===================================================================
+dnl Check for WiX tools.
+dnl ===================================================================
+if test "$enable_wix" = "" -o "enable_wix" = "no"; then
+ AC_MSG_RESULT([no])
+ ENABLE_WIX=
+else
+ AC_MSG_RESULT([yes])
+ if ! which candle >/dev/null 2>&1; then
+ AC_MSG_ERROR([WiX requested but WiX toolset not found.])
+ fi
+ ENABLE_WIX=TRUE
+fi
+AC_SUBST(ENABLE_SILENT_MSI)
+
AC_MSG_CHECKING([whether and how to use Xinerama])
if test "$_os" = "Linux" -o "$_os" = "FreeBSD"; then
if test "$x_libraries" = "default_x_libraries"; then