summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a0b6ed5ff9a0..823fcddf43d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1822,7 +1822,7 @@ AC_ARG_WITH(libbase-jar,
AC_ARG_WITH(system-odbc,
AS_HELP_STRING([--with-system-odbc],
[Use the odbc headers already on system.]),,
- [with_system_odbc="$with_system_headers"])
+ [with_system_odbc="auto"])
AC_ARG_WITH(system-sane,
AS_HELP_STRING([--with-system-sane],
@@ -8598,7 +8598,7 @@ dnl ===================================================================
dnl Check for system odbc
dnl ===================================================================
AC_MSG_CHECKING([which odbc headers to use])
-if test "$with_system_odbc" = "yes" ; then
+if test "$with_system_odbc" = "yes" -o '(' "$with_system_headers" = "yes" -a "$with_system_odbc" = "auto" ')' -o '(' "$_os" = "WINNT" -a "$with_system_odbc" != "no" ')'; then
AC_MSG_RESULT([external])
SYSTEM_ODBC_HEADERS=TRUE