summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c4367d9c1dd7..a0b6ed5ff9a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2783,7 +2783,6 @@ if test $_os = Darwin; then
;;
esac
- # If no CC and CXX environment vars, try to guess where the compiler is
LIBTOOL=libtool
INSTALL_NAME_TOOL=install_name_tool
if test -z "$save_CC"; then
@@ -8603,8 +8602,19 @@ if test "$with_system_odbc" = "yes" ; then
AC_MSG_RESULT([external])
SYSTEM_ODBC_HEADERS=TRUE
- AC_CHECK_HEADER(sqlext.h, [],
- [AC_MSG_ERROR(odbc not found. install odbc)], [])
+ if test "$build_os" = "cygwin"; then
+ save_CPPFLAGS=$CPPFLAGS
+ find_winsdk
+ PathFormat "$winsdktest"
+ CPPFLAGS="$CPPFLAGS -I$formatted_path/include/um -I$formatted_path/include -I$formatted_path/include/shared"
+ AC_CHECK_HEADER(sqlext.h, [],
+ [AC_MSG_ERROR(odbc not found. install odbc)],
+ [#include <windows.h>])
+ CPPFLAGS=$save_CPPFLAGS
+ else
+ AC_CHECK_HEADER(sqlext.h, [],
+ [AC_MSG_ERROR(odbc not found. install odbc)],[])
+ fi
elif test "$enable_database_connectivity" != yes; then
AC_MSG_RESULT([none])
else