summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7c8c807c745..687965c443c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9948,6 +9948,15 @@ if test $build_os = cygwin; then
fi
dnl ===================================================================
+dnl We need touch with -h option support.
+dnl ===================================================================
+AC_PATH_PROG(TOUCH, touch)
+test -z "$TOUCH" && AC_MSG_ERROR([touch is required])
+if ! "$TOUCH" -h /dev/null 2>/dev/null > /dev/null; then
+ AC_MSG_ERROR([touch version with -h option support is required to build, please install it and make sure it is the one found first in PATH],,)
+fi
+
+dnl ===================================================================
dnl Test which vclplugs have to be built.
dnl ===================================================================
R=""