summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 971d7ad440c5..4652067a64de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2576,6 +2576,17 @@ AC_ARG_WITH(vendor,
[Set vendor of the build.]),
,)
+AC_ARG_WITH(privacy-policy-url,
+ AS_HELP_STRING([--with-privacy-policy-url="https://yourdomain/privacy-policy"],
+ [The URL to your privacy policy (needed when
+ enabling online-update or crashreporting via breakpad)]),
+ [if test "x$with_privacy_policy_url" = "xyes"; then
+ AC_MSG_FAILURE([you need to specify an argument when using --with-privacy-policy-url])
+ elif test "x$with_privacy_policy_url" = "xno"; then
+ with_privacy_policy_url="undefined"
+ fi]
+,[with_privacy_policy_url="undefined"])
+
AC_ARG_WITH(android-package-name,
AS_HELP_STRING([--with-android-package-name="org.libreoffice"],
[Set Android package name of the build.]),
@@ -12946,6 +12957,14 @@ AC_SUBST(ENABLE_ONLINE_UPDATE)
AC_SUBST(ENABLE_ONLINE_UPDATE_MAR)
AC_SUBST(UPDATE_CONFIG)
+
+PRIVACY_POLICY_URL="$with_privacy_policy_url"
+if test "$ENABLE_ONLINE_UPDATE" = TRUE -o "$ENABLE_BREAKPAD" = "TRUE"; then
+ if test "x$with_privacy_policy_url" = "xundefined"; then
+ AC_MSG_FAILURE([online update or breakpad/crashreporting are enabled, but no privacy url was provided])
+ fi
+fi
+AC_SUBST(PRIVACY_POLICY_URL)
dnl ===================================================================
dnl Test whether we need bzip2
dnl ===================================================================