summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 18 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a31b26c62ab9..4a2d71a04877 100644
--- a/configure.ac
+++ b/configure.ac
@@ -949,6 +949,24 @@ if test $_os != "WINNT"; then
fi
AC_SUBST(DLOPEN_LIBS)
+AC_ARG_ENABLE(ios-simulator,
+ AS_HELP_STRING([--enable-ios-simulator],
+ [build i386 or x86_64 for ios simulator])
+)
+
+AC_ARG_ENABLE(ios-libreofficelight-app,
+ AS_HELP_STRING([--enable-ios-libreofficelight-app],
+ [When building for iOS, build stuff relevant only for the 'LibreOfficeLight' app
+ (in ios/LibreOfficeLight). Note that this app is not known to work in any useful manner,
+ and also that its actual build (in Xcode) requires some obvious modifications to the project.])
+)
+
+ENABLE_IOS_LIBREOFFICELIGHT_APP=
+if test "$enable_ios_libreofficelight_app" = yes; then
+ ENABLE_IOS_LIBREOFFICELIGHT_APP=TRUE
+fi
+AC_SUBST(ENABLE_IOS_LIBREOFFICELIGHT_APP)
+
###############################################################################
# Extensions switches --enable/--disable
###############################################################################
@@ -962,11 +980,6 @@ AC_SUBST(DLOPEN_LIBS)
# if you use --disable-extension-integration. Is that really the
# case?
-AC_ARG_ENABLE(ios-simulator,
- AS_HELP_STRING([--enable-ios-simulator],
- [build i386 or x86_64 for ios simulator])
-)
-
libo_FUZZ_ARG_ENABLE(extension-integration,
AS_HELP_STRING([--disable-extension-integration],
[Disable integration of the built extensions in the installer of the