summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 0 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 315bffaf9ae6..daa1810cd6a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8761,11 +8761,6 @@ if test "$with_system_boost" = "yes"; then
[AC_MSG_ERROR(boost/spirit/include/classic_core.hpp not found. install boost >= 1.36)], [])
AC_CHECK_HEADER(boost/function.hpp, [],
[AC_MSG_ERROR(boost/function.hpp not found. install boost)], [])
- AC_MSG_CHECKING([whether boost signals2 works])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <boost/signals2/signal.hpp>]],
- [[ boost::signals2::signal<void()> s; s(); ]])],
- [AC_MSG_RESULT([yes])],
- [AC_MSG_ERROR([no, install boost >= 1.55 or use --without-system-boost])])
CXXFLAGS="$CXXFLAGS -fno-exceptions"
AC_MSG_CHECKING([whether boost/function.hpp compiles with -fno-exceptions])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <boost/function.hpp>