summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 563fd831f18e..85ff8c3c0f55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,7 +142,21 @@ PathFormat()
fi
if test "$build_os" = "wsl"; then
if test "$fp_count_colon" != "0"; then
- formatted_path=$(wslpath -m $(wslpath "$formatted_path"))
+ formatted_path=$(wslpath "$formatted_path")
+ local final_slash=
+ case "$formatted_path" in
+ */)
+ final_slash=/
+ ;;
+ esac
+ formatted_path=$(wslpath -m $formatted_path)
+ case "$formatted_path" in
+ */)
+ ;;
+ *)
+ formatted_path="$formatted_path"$final_slash
+ ;;
+ esac
else
formatted_path=$(wslpath -m "$formatted_path")
fi