summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bfc00bd49ad9..07c7d13c8570 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1948,7 +1948,7 @@ AC_ARG_WITH(windows-sdk,
AC_ARG_WITH(lang,
AS_HELP_STRING([--with-lang],
- [Use this option to build LibreOffice with additional language support.
+ [Use this option to build LibreOffice with additional UI language support.
English (US) is always included by default.
Separate multiple languages with space.
For all languages, use --with-lang=ALL.])
@@ -1957,6 +1957,20 @@ AC_ARG_WITH(lang,
],
,)
+AC_ARG_WITH(locales,
+ AS_HELP_STRING([--with-locales],
+ [Use this option to limit the locale information built in.
+ By default all the locales available is included.
+ This option is completely unrelated to --with-lang.
+ Separate multiple locales with space.
+ For the default, all locales, don't use this switch at all.
+ Specifying just the language part of a locale means all matching
+ locales will be included.])
+ [
+ Usage: --with-locales="en es pt fr zh kr ja"
+ ],
+,)
+
# Kerberos and GSSAPI used only by PostgreSQL as of LibO 3.5
AC_ARG_WITH(krb5,
AS_HELP_STRING([--with-krb5],
@@ -12185,6 +12199,11 @@ if test -d "$SRC_ROOT/translations/source"; then
fi
AC_SUBST(WITH_POOR_HELP_LOCALIZATIONS)
+if test -n "$with_locales"; then
+ WITH_LOCALES="$with_locales"
+fi
+AC_SUBST(WITH_LOCALES)
+
dnl git submodule update --reference
dnl ===================================================================
if test -n "${GIT_REFERENCE_SRC}"; then