summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e03d7fc1c80b..19b227786bcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10507,7 +10507,15 @@ dnl ===================================================================
dnl Check for system NSS
dnl ===================================================================
if test "$enable_fuzzers" != "yes" -a "$enable_nss" = "yes"; then
- libo_CHECK_SYSTEM_MODULE([nss],[NSS],[nss >= 3.9.3 nspr >= 4.8])
+ libo_CHECK_SYSTEM_MODULE([nss],[NSS],[nss >= 3.9.3 nspr >= 4.8],,,[
+ case "$_os" in
+ Linux)
+ with_system_nss=yes
+ ;;
+ *)
+ with_system_nss=no
+ ;;
+ esac])
AC_DEFINE(HAVE_FEATURE_NSS)
ENABLE_NSS=TRUE
elif test $_os != iOS ; then