summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ec8c92af30f6..5e20fc4d4271 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9703,9 +9703,9 @@ for a in "$NINJA" ninja ninja-build; do
$a --version > /dev/null 2>/dev/null
if test $? -eq 0; then
if test "$build_os" = "cygwin"; then
- # nss requires the Windows version of ninja
+ # nss requires the Windows version of ninja (but uses its Unix path)
if test -n "$($a -t list | grep 'msvc')" ; then
- NINJA="$(cygpath -m "$(which "$(cygpath -u $a)")")"
+ NINJA=`which $a`
fi
else
NINJA=`which $a`
@@ -9724,6 +9724,7 @@ fi
if test -z "$NINJA" -a "$nss_needs_ninja" = "yes" -a -n "$ENABLE_NSS" -a -z "$SYSTEM_NSS"; then
AC_MSG_ERROR([Not found. NSS build requires Ninja (https://ninja-build.org/).])
fi
+AC_SUBST(NINJA)
dnl ===================================================================
dnl Check for TLS/SSL and cryptographic implementation to use