summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 6 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 4c1e4f47b2c8..8eea72fa4938 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1383,26 +1383,9 @@ libo_FUZZ_ARG_ENABLE(online-update,
enabled instead of the traditional update mechanism.]),
,)
-AC_ARG_WITH(update-channel,
- AS_HELP_STRING([--with-update-channel=master-daily],
- [Defines the update channel used by the updater.]),
-,with_update_channel=master-daily)
-
-AC_ARG_WITH(update-certificate-name,
- AS_HELP_STRING([--with-update-certificate-name=master-daily],
- [Defines the name of the certificate that should be used to sign the mar files.
- This makes only sense if the onlineupdate is used and the mar files should be uploaded.]))
-
-AC_ARG_WITH(update-certificate-path,
- AS_HELP_STRING([--with-update-certificate-name=master-daily],
- [Defines the path to the nss certificate store used for the updater
- This makes only sense if the onlineupdate is used and the mar files should be uploaded.]))
-
-AC_ARG_WITH(update-base-url,
- AS_HELP_STRING([--with-update-base-url=http://dev-builds.libreoffice.org/update/$(channel)/$(buildid)],
- [Defines the base url for the mar file url. THe following variables are going to be replaced
- with the corresponding content: channel, buildid, version, platform, productname.
- This makes only sense if the onlineupdate is used and the mar files should be uploaded.]))
+AC_ARG_WITH(update-config,
+ AS_HELP_STRING([--with-update-config=/tmp/update.ini],
+ [Path to the update config ini file]))
libo_FUZZ_ARG_ENABLE(extension-update,
AS_HELP_STRING([--disable-extension-update],
@@ -11324,10 +11307,7 @@ dnl ===================================================================
AC_MSG_CHECKING([whether to enable online update])
ENABLE_ONLINE_UPDATE=
ENABLE_ONLINE_UPDATE_MAR=
-UPDATE_CHANNEL=
-UPDATE_CERTIFICATE_NAME=
-UPDATE_CERTIFICATE_PATH=
-UPDATE_BASE_URL=
+UPDATE_CONFIG=
if test "$enable_online_update" = ""; then
if test "$_os" = "WINNT" -o "$_os" = "Darwin"; then
AC_MSG_RESULT([yes])
@@ -11339,11 +11319,8 @@ else
if test "$enable_online_update" = "mar"; then
AC_MSG_RESULT([yes - MAR-based online update])
ENABLE_ONLINE_UPDATE_MAR="TRUE"
+ UPDATE_CONFIG="$with_update_config"
AC_DEFINE(HAVE_FEATURE_UPDATE_MAR)
- UPDATE_CHANNEL="$with_update_channel"
- UPDATE_CERTIFICATE_NAME="$with_update_certificate_name"
- UPDATE_CERTIFICATE_PATH="$with_update_certificate_path"
- UPDATE_BASE_URL="$with_update_base_url"
elif test "$enable_online_update" = "yes"; then
AC_MSG_RESULT([yes])
ENABLE_ONLINE_UPDATE="TRUE"
@@ -11353,10 +11330,7 @@ else
fi
AC_SUBST(ENABLE_ONLINE_UPDATE)
AC_SUBST(ENABLE_ONLINE_UPDATE_MAR)
-AC_SUBST(UPDATE_CHANNEL)
-AC_SUBST(UPDATE_CERTIFICATE_NAME)
-AC_SUBST(UPDATE_CERTIFICATE_PATH)
-AC_SUBST(UPDATE_BASE_URL)
+AC_SUBST(UPDATE_CONFIG)
dnl ===================================================================
dnl Test whether we need bzip2