summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b00c4d7bc6b8..6b1571c8edd0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1300,6 +1300,12 @@ AC_ARG_ENABLE(macosx-sandbox,
adherence to App Store rules.]),
,)
+AC_ARG_WITH(macosx-teamid,
+ AS_HELP_STRING([--with-macosx-teamid=<teamid>],
+ [The "team id" to be used for com.apple.application-identifier
+ in the entitlements when building a sandboxed LibreOffice.]),
+,)
+
AC_ARG_ENABLE(canonical-installation-tree-structure,
AS_HELP_STRING([--enable-canonical-installation-tree-structure],
[Make the installation tree structure be more canonical for
@@ -3059,8 +3065,14 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([whether to sandbox the application])
+ if test -n "$with_macosx_teamid" -a "$with_macosx_teamid != yes -a "$with_macosx_teamid != no; then
+ MACOSX_TEAMID="$with_macosx_teamid"
+ fi
+
if test -z "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
AC_MSG_ERROR([OS X sandboxing requires code signing])
+ elif test -z "$MACOSX_TEAMID" -a "$enable_macosx_sandbox" = yes; then
+ AC_MSG_ERROR([OS X sandboxing requires a team id])
elif test -n "$ENABLE_JAVA" -a "$enable_macosx_sandbox" = yes; then
AC_MSG_ERROR([OS X sandboxing (actually App Store rules) disallows use of Java])
elif test -n "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
@@ -3098,6 +3110,7 @@ AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(MACOSX_PACKAGE_SIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
+AC_SUBST(MACOSX_TEAMID)
AC_SUBST(MACOSX_APP_NAME)
AC_SUBST(MACOSX_HIGH_RESOLUTION_VALUE)